Competitive Programming: POJ 2318 – TOYS

 

Description

Calculate the number of toys that land in each bin of a partitioned toy box.

Mom and dad have a problem – their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John’s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.

Bow with partitions

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n, m, x1, y1, x2, y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x_1,y_1) and (x_2,y_2), respectively. The following n lines contain two integers per line — U_i, L_i — indicating that the ends of the i-th cardboard partition is at the coordinates (U_i,y_1) and (L_i,y_2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, X_j, Y_j specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are “in” the box.

Link to problem

Solution below . . .

Solution

/*
 * 1. Read in the problem parameters.
 * 2. Read and store the start and end points of the partitions in a
 *    pair of arrays.
 * 3. Add the right edge of the box to the partition arrays.
 * 4. For each toy, find the closest partition that lies to the right
 *    of the toy. That gives us the bin number.
 *    a. Since we're assured that the partitions are ordered left to 
 *       right, we can binary search the partition arrays rather than 
 *       searching sequentially.
 *    b. Projecting a toy location onto a partition and comparing the
 *       a coordinates tells us if the toy is right or left of the
 *       partition.
 */

import java.util.Scanner;

public class Main {

  static final double EPS = 1e-12;

  static double dot(PT p, PT q) {
    return p.x * q.x + p.y * q.y;
  }

  // project point c onto line segment through a and b
  static PT ProjectPointSegment(PT a, PT b, PT c) {
    double r = dot(b.subtract(a), b.subtract(a));
    if (Math.abs(r) < EPS)
      return a;
    r = dot(c.subtract(a), b.subtract(a)) / r;
    if (r < 0)
      return a;
    if (r > 1)
      return b;
    return a.add(b.subtract(a).multiply(r));
  }

  public static void main(String[] args) {

    Scanner sc = new Scanner(System.in);

    while (sc.hasNext()) {
      int n = sc.nextInt();

      if (n == 0)
        break;

      int m = sc.nextInt();
      int x1 = sc.nextInt();
      int y1 = sc.nextInt();
      int x2 = sc.nextInt();
      int y2 = sc.nextInt();

      PT[] P = new PT[n + 1];
      PT[] Q = new PT[n + 1];

      PT p, q;

      for (int i = 0; i < n; i++) {
        p = new PT(sc.nextInt(), y1);
        q = new PT(sc.nextInt(), y2);

        P[i] = p;
        Q[i] = q;
      }

      p = new PT(x2, y1);
      q = new PT(x2, y2);

      P[n] = p;
      Q[n] = q;

      int[] counts = new int[n + 1];

      for (int i = 0; i < m; i++) {
        PT toy = new PT(sc.nextInt(), sc.nextInt());

        int low = 0;
        int high = n;
        int bin = -1;
        double min = Double.POSITIVE_INFINITY;

        // binary search
        while (low <= high) {
          int mid = low + (high - low) / 2;
          PT proj = ProjectPointSegment(P[mid], Q[mid], toy);

          if (proj.x > toy.x) {
            double diff = proj.x - toy.x;
            if (diff < min) {
              min = diff;
              bin = mid;
            }
            high = mid - 1;
          } else {
            low = mid + 1;
          }
        }
        counts[bin]++;
      }

      for (int i = 0; i < counts.length; i++) {
        System.out.println(i + ": " + counts[i]);
      }
      System.out.println();
    }
    sc.close();
  }
}

class PT {
  double x, y;

  PT(double x, double y) {
    this.x = x;
    this.y = y;
  }

  PT add(final PT p) {
    return new PT(x + p.x, y + p.y);
  }

  PT subtract(final PT p) {
    return new PT(x - p.x, y - p.y);
  }

  PT multiply(double c) {
    return new PT(x * c, y * c);
  }

  PT divide(double c) {
    return new PT(x / c, y / c);
  }
}

Leave a Reply

Your email address will not be published. Required fields are marked *