Competitive Programming: SPOJ – Glass Beads

 

Link to problem

Once upon a time there was a famous actress. As you may expect, she played mostly Antique Comedies most of all. All the people loved her. But she was not interested in the crowds. Her big hobby were beads of any kind. Many bead makers were working for her and they manufactured new necklaces and bracelets every day. One day she called her main Inspector of Bead Makers (IBM) and told him she wanted a very long and special necklace.

The necklace should be made of glass beads of different sizes connected to each other but without any thread running through the beads, so that means the beads can be disconnected at any point. The actress chose the succession of beads she wants to have and the IBM promised to make the necklace. But then he realized a problem. The joint between two neighbouring beads is not very robust so it is possible that the necklace will get torn by its own weight. The situation becomes even worse when the necklace is disjoined. Moreover, the point of disconnection is very important. If there are small beads at the beginning, the possibility of tearing is much higher than if there were large beads. IBM wants to test the robustness of a necklace so he needs a program that will be able to determine the worst possible point of disjoining the beads.

The description of the necklace is a string A = a_{1}a_{2} ... a_{m} specifying sizes of the particular beads, where the last character a_{m} is considered to precede character a_{1} in circular fashion.

The disjoint point i is said to be worse than the disjoint point j if and only if the string a_{i}a_{i+1} ... a_{n}a_{1} ... a_{i-1} is lexicographically smaller than the string a_{j}a_{j+1} ... a_{n}a_{1} ... a_{j-1}. String a_{1}a_2 ... a_n is lexicographically smaller than the string b_1b_2 ... b_n if and only if there exists an integer i, i \leq n, so that a_j = b_j, for each j, 1 \leq j < i and a_i < b_i.

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line containing necklace description. Maximal length of each description is 10000 characters. Each bead is represented by a lower-case character of the English alphabet (a–z), where a < b … z.

Output

For each case, print exactly one line containing only one integer — number of the bead which is the first at the worst possible disjoining, i.e. such i, that the string A[i] is lexicographically smallest among all the n possible disjoinings of a necklace. If there are more than one solution, print the one with the lowest i.

Time limit: 0.5s

Sample input
 
4
helloworld
amandamanda
dontcallmebfu
aaabaaa
 
Sample output
 
10
11
6
5
 

Solution below . . .

Solution

What we want is a lexicographically minimal string rotation.

An obvious solution is to iterate through all possible rotations while keeping track of the lexicographical minimum. For a string of length n, this is O(n^2), too slow for 10,000-character strings and a 0.5 second time limit.

Booth’s Algorithm solves the lexicographically minimal string rotation problem with an O(n) modification of the preprocessing function of the Knuth-Morris-Pratt (KMP) Algorithm. The implementation is straightforward.

import java.util.Scanner;

class Main {

  static void booth(String S) {
    
    // Concatenate string to itself to avoid modular arithmetic
    S += S; 

    char[] arrCh = S.toCharArray();

    int[] failure = new int[S.length()];
    for (int i = 0; i < failure.length; i++) {
      failure[i] = -1;
    }

    int k = 0; // Minimal rotation of string found so far
    for (int j = 1; j < S.length(); j++) {
      int sj = arrCh[j];
      int i = failure[j - k - 1];

      while (i != -1 && sj != arrCh[k + i + 1]) {
        if (sj < arrCh[k + i + 1]) {
          k = j - i - 1;
        }
        i = failure[i];
      }
      if (sj != arrCh[k + i + 1]) { 
        if (sj < arrCh[k]) { 
          k = j;
        }
        failure[j - k] = -1;
      } else {
        failure[j - k] = i + 1;
      }
    }
    
    // add 1 to answer because problem uses 1-based indexing
    System.out.println(k+1);
  }


  public static void main(String[] args) {

    Scanner sc = new Scanner(System.in);

    int N = sc.nextInt();

    while (N-- > 0) {
      booth(sc.next());
    }

    sc.close();
  }
}

Leave a Reply

Your email address will not be published. Required fields are marked *